<!doctype html>
      <html class="single desktop layout-clean fixed-full-width" lang="en">
        <head>
          <title>"Fluffy" Showed Up Hungry for Some Comedy in Montana</title>
          <meta http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta charset="UTF-8"/><meta name="instagram_profile" value="newstalk970"/><meta name="description" content="Let&#x27;s just say Fluffy was hungry to put on a show, especially after all the COVID shutdowns. Comedian Gabriel Iglesias was back in Billings, Montana."/><meta name="keywords" content="fluffy in billings, gabriel iglesias in montana,billings events,billings news,montana news,montana talks,newsletter,politics"/><meta property="fb:app_id" content="1090896361388279"/><meta property="fb:admins" content="1249730544"/><meta property="fb:admins" content="583052867"/><meta property="fb:admins" content="100002025987268"/><meta property="fb:admins" content="732998853"/><meta property="fb:use_automatic_ad_placement" content="false"/><meta property="og:title" content="&#x22;Fluffy&#x22; Showed Up Hungry for Some Comedy in Montana"/><meta property="og:description" content="Gabriel Iglesias was back in Billings, Montana for his second show of the year."/><meta property="og:url" content="https://newstalk955.com/fluffy-showed-up-hungry-for-some-comedy-in-montana/"/><meta property="og:site_name" content="NewsTalk 95.5"/><meta property="og:type" content="article"/><meta property="og:image:width" content="1200"/><meta property="og:image:height" content="630"/><meta property="og:image" content="https://townsquare.media/site/125/files/2022/01/attachment-Fluffy1.jpg?w=1200&#x26;h=0&#x26;zc=1&#x26;s=0&#x26;a=t&#x26;q=89"/><meta name="twitter:card" content="summary_large_image"/><meta name="sailthru.description" content="Let&#x27;s just say Fluffy was hungry to put on a show, especially after all the COVID shutdowns. Comedian Gabriel Iglesias was back in Billings, Montana."/><meta name="sailthru.date" content="2022-01-16 19:29:34"/><meta name="sailthru.title" content="&#x201C;Fluffy&#x201D; Showed Up Hungry for Some Comedy in Montana"/><meta name="sailthru.tags" content="tsmsite-kchh-kbul, tsmmarket-billings, tsmtype-local, comedy, billings-events, local-news-2, montana-news, montana-talks, newsletter, politics"/><meta name="sailthru.author" content="aaronflint"/><meta name="sailthru.image.full" content="https://townsquare.media/site/125/files/2022/01/attachment-Fluffy1.jpg"/><meta name="sailthru.image.thumb" content="https://townsquare.media/site/125/files/2022/01/attachment-Fluffy1.jpg"/><meta name="google-site-verification" content="f0rgScI0R4mSxnCslGn9EBjC4ABGuNzEBCG-dq8aN9I"/><meta property="fb:pages" content="220346177980133"/><meta name="robots" content="max-image-preview:large"/>
          <link rel="preload" href="/styles/desktop/base.css?ver=b7dd1c09524cc4d70c12723e11a7f52ec00a62db&mver=36&gver=3" as="style"/><link rel="preload" href="//townsquare.media/public/dist/desktop/main.bundle.b7dd1c09524cc4d70c12723e11a7f52ec00a62db.js?mver=36&gver=3" as="script"/><link rel="preconnect" href="https://px.owneriq.net" crossorigin /><link rel="preconnect" href="https://static.solutionshindsight.net" crossorigin /><link rel="preconnect" href="https://partner.linkfire.com" crossorigin /><link rel="preconnect" href="https://btloader.com" crossorigin /><link rel="preconnect" href="https://ads.blogherads.com" crossorigin /><link rel="preconnect" href="https://action.dstillery.com" crossorigin /><link rel="preconnect" href="https://d15kdpgjg3unno.cloudfront.net" crossorigin /><link rel="preconnect" href="https://content.cdn.targetspot.com" crossorigin />
          <link id="design-fav" rel="shortcut icon" href="https://townsquare.media/site/125/files/2014/01/favicon.ico"/><link rel="profile" href="http://gmpg.org/xfn/11"/><link rel="prev" title="Have You Seen This Billboard Near Bozeman Yet?" href="https://newstalk955.com/have-you-seen-this-billboard-near-bozeman-yet/"/><link rel="canonical" href="https://newstalk955.com/fluffy-showed-up-hungry-for-some-comedy-in-montana/"/><link rel="apple-touch-icon-precomposed" href="https://townsquare.media/wp-content/uploads/2019/05/KCHH-KBULAM.png?h=57&w=57"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://townsquare.media/wp-content/uploads/2019/05/KCHH-KBULAM.png?h=114&w=114"/><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://townsquare.media/wp-content/uploads/2019/05/KCHH-KBULAM.png?h=72&w=72"/>
          <!-- <link href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300|Roboto+Condensed:300,400,700&display=swap" rel="stylesheet" type="text/css" /> -->
          <!-- connect to domain of font files -->
          <link rel="preconnect" href="https://fonts.googleapis.com" crossorigin/>
          <!-- optionally increase loading priority -->
          <link rel="preload" as="style" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300|Roboto+Condensed:300,400,700&display=swap">
          <!-- async CSS -->
          <link rel="stylesheet" media="print" onload="this.onload=null;this.removeAttribute('media');" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300|Roboto+Condensed:300,400,700&display=swap">
          <!-- no-JS fallback -->
          <noscript>
            <link rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300|Roboto+Condensed:300,400,700&display=swap">
          </noscript>
          <link href="/styles/desktop/base.css?ver=b7dd1c09524cc4d70c12723e11a7f52ec00a62db&mver=36&gver=3" rel="stylesheet" type="text/css" />
          <script>window.TSM = window.TSM ||{}; window.TSM.fn = window.TSM.fn || {}; window.TSM.fn.isIe = function(n){var t,i;return(n=n||"",!n||n===null||typeof n=="undefined"||n&&!n.match)?!1:(t=n.match(/MSIEs([d.]+)/i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):(t=n.match(/Trident.*rv[ :]*(11)./i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):!1};
      window.TSM.fn.getFile=function(n,t={},i=document.body){return new Promise(function(r){var e=function(n){n.target.removeEventListener("load",e);r(n.target)},u=document.createElement("script"),f;u.addEventListener("load",e);u.src=n;for(f in t)u.setAttribute(f,t[f]);i.appendChild(u)})};
    </script>
          <script>window.taskQ=[];</script>
          
        <script type="text/javascript">
          window.TSM = window.TSM || {q:[]};
          window.TSM.abgroup = "B";
          window.TSM.cadata = {"activeDomain":"newstalk955.com","blogId":125,"method":"get_single","postId":294380,"postType":"post","postDateGmt":"2022-01-17 02:29:34.000+0000"};
          window.TSM.startload = new Date().getTime();
        </script>
          <script>
    (function () {
      function getCookie(name) {
        var value = "; " + document.cookie;
        var parts = value.split("; " + name + "=");
        if (parts.length == 2) return parts.pop().split(";").shift();
      }
      function updateCookie(name, value, expireDays) {
        let d = new Date();
        d.setTime(d.getTime() + (60*60*24*expireDays*1000));
        var expires = "expires="+ d.toUTCString();
        document.cookie = name + "=" + value + ";" + expires + ";path=/";
      }
      window.TSM = window.TSM || {};
      if (window.TSM.abgroup) {
        updateCookie("abgroup", window.TSM.abgroup, 90);
      }

      var xhr = new XMLHttpRequest();
      xhr.open("POST", "/rest/high/api/cogitoergosum", true);
      var cogitoergosum = getCookie("cogitoergosum");
      var abgroup = getCookie("abgroup");
      if (cogitoergosum) {
        window.TSM.cogitoergosum = JSON.parse( atob( decodeURIComponent( cogitoergosum ) ) );
      }
      xhr.onreadystatechange = function() {//Call a function when the state changes.
        if(xhr.readyState == XMLHttpRequest.DONE && xhr.status == 200) {
          if (xhr.response) {
            var result = JSON.parse(xhr.response);
            if (result && result.result) {
              if (result.result.cookie) {
                window.TSM.cogitoergosum = JSON.parse( atob( result.result.cookie ) );
              }
              if (result.result.credentials) {
                window.TSM.credentials = JSON.parse( atob( result.result.credentials ) );
              }
              // console.log("cogitoergosum xhr", window.TSM.cogitoergosum);
            }
          }
        }
      };
      xhr.setRequestHeader("Content-type", "application/json");
      var cadata = window.TSM.cadata || {};
      cadata.experimentGroup = window.TSM.abgroup;
      cadata.viewType = "standard";
      cadata.timespent = new Date().getTime() - window.TSM.startload;
      var referrer = document.referrer;
      var sendData = {
        type: "pageview",
        referrer: referrer,
        url: document.location.href,
        queryParam: document.location.queryParam,
        pageData: cadata,
        scrollPageIndex: 0
      };
      xhr.send(JSON.stringify(sendData));
    }());
  </script>
          <script>
            (function(w){
              w.ga=w.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
              var gaInitData = {"hitType":"pageview","dimension1":"aaronflint","dimension2":"billings-events,local-news-2,montana-news,montana-talks,newsletter,politics","dimension3":"comedy,montana-talks-forced","dimension4":"post","dimension5":"Sun Jan 16 2022","dimension6":"19:29","dimension7":"standard","dimension8":"1264","dimension9":"B","dimension10":"yes","dimension12":"","dimension13":"","dimension14":""};
gaInitData.dimension13=function(){let refData=sessionStorage.getItem("itemRef"),str=[];return refData&&(refData=JSON.parse(refData),refData.title&&(str.push(refData.title),str.push(refData.source||"NA")),sessionStorage.removeItem("itemRef")),str.join(" -|- ");}();
window.globalDimensionData = {"dimension1":"aaronflint","dimension2":"billings-events,local-news-2,montana-news,montana-talks,newsletter,politics","dimension3":"comedy,montana-talks-forced","dimension4":"post","dimension5":"Sun Jan 16 2022","dimension6":"19:29","dimension7":"standard","dimension8":"1264","dimension9":"B","dimension10":"yes","dimension12":"","dimension13":"","dimension14":""};
ga( "create", {
          trackingId:"UA-19111666-5",
          name: "primary",
          allowAnchor: false
        });
        
        ga( "primary.require", "displayfeatures" );
        ga( "primary.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "primary.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "primary" ] = {gaid:"UA-19111666-5"};
ga( "create", {
          trackingId:"UA-19109753-1",
          name: "UA191097531",
          allowAnchor: false
        });
        
        ga( "UA191097531.require", "displayfeatures" );
        ga( "UA191097531.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA191097531.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA191097531" ] = {gaid:"UA-19109753-1"};
ga( "create", {
          trackingId:"UA-19111666-6",
          name: "UA191116666",
          allowAnchor: false
        });
        
        ga( "UA191116666.require", "displayfeatures" );
        ga( "UA191116666.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA191116666.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA191116666" ] = {gaid:"UA-19111666-6"};
ga( "create", {
          trackingId:"UA-28825804-2",
          name: "UA288258042",
          allowAnchor: false
        });
        
        ga( "UA288258042.require", "displayfeatures" );
        ga( "UA288258042.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA288258042.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA288258042" ] = {gaid:"UA-28825804-2"};
ga( "create", {
          trackingId:"UA-45260060-1",
          name: "UA452600601",
          allowAnchor: false
        });
        
        ga( "UA452600601.require", "displayfeatures" );
        ga( "UA452600601.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "UA452600601.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "UA452600601" ] = {gaid:"UA-45260060-1"};
            })(window);
          </script>
          <script async defer src="https://www.google-analytics.com/analytics.js"></script>
          <script async defer src="//townsquare.media/public/resources/js/autotrack.carbon.js"></script>
          <script>(function(w){
      w.dataLayer = [{"title":"\"Fluffy\" Showed Up Hungry for Some Comedy in Montana","callsign":"KBULAM","market":"Billings","sitetype":"Local","siteClassification":"Local","state":"MT","genre":"news-talk","pageType":"post","tags":"comedy,montana-talks-forced","categories":"billings-events,local-news-2,montana-news,montana-talks,newsletter,politics","mediaType":"gallery"}];
      w.dataLayer[0].referer = document.referrer;w.dataLayer[0].curatedReferer = document.referrer.replace( /https?:\/\//, "" );w.dataLayer[0].dayOfWeek = function(n){return n.toLocaleString("en-US",{weekday:"long"})}(new Date);w.dataLayer[0].periodOfDay = function(n,t,i){t=n.getHours(),i=n.getMinutes(),i<10&&(i="0"+i);var r=parseInt(t+""+i);return r>=0&&r<600?"Overnight":r>=600&&r<1e3?"Morning Drive":r>=1e3&&r<1500?"Midday":r>=1500&&r<1900?"Afternoon Drive":r>=1900&&r<2400?"Evening":void 0}(new Date);
    })(window);</script>
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start": new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src= "https://www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f); })(window,document,"script","dataLayer","GTM-K346HJZ");});</script>
          <script>
        window.taskQ=window.taskQ||[];window.taskQ.push(function(){
          (function(w,dl){
            var
              isUS = RegExp( "us-region-source=CA" ).exec( document.cookie );
            const
              addOipScript = function(){
                if( dl && dl[0] ){
                  dl = dl[0];
                  w._oiqq = w._oiqq || [];
                  var keywordMeta = document.querySelector( "meta[name='keywords']");
                  _oiqq.push(["oiq_addPageBrand", "title:" + dl.title]);
                  _oiqq.push(["oiq_addPageBrand", "domain:" + location.hostname]);
                  _oiqq.push(["oiq_addPageBrand", "callsign:" + dl.callsign]);
                  _oiqq.push(["oiq_addPageCat", "url_path:" + location.pathname]);
                  _oiqq.push(["oiq_addPageCat", "meta_keywords:" + ( keywordMeta ? keywordMeta.content : "" ) ]);
                  _oiqq.push(["oiq_addPageCat", "title:" + dl.title]);
                  _oiqq.push(["oiq_addPageCat", "callsign:" + dl.callsign]);
                  _oiqq.push(["oiq_addPageCat", "market:" + dl.market]);
                  _oiqq.push(["oiq_addPageCat", "sitetype:" + dl.sitetype]);
                  _oiqq.push(["oiq_addPageCat", "state:" + dl.state]);
                  _oiqq.push(["oiq_addPageCat", "page_type:" + dl.pageType]);
                  _oiqq.push(["oiq_addPageCat", "media_type:" + dl.mediaType]);
                  _oiqq.push(["oiq_addPageCat", "day_of_week:" + dl.dayOfWeek]);
                  _oiqq.push(["oiq_addPageCat", "newsletter_submission:" + (dl.newsletterSubmission || "no")]);
                  _oiqq.push(["oiq_addPageCat", "period_of_day:" + dl.periodOfDay]);
                  _oiqq.push(["oiq_addPageCat", "curated_referer:" + dl.curatedReferer]);
                  _oiqq.push(["oiq_addPageCat", "genre:" + dl.genre]);
                  _oiqq.push(["oiq_addPageCat", "tags:" + dl.tags]);
                  _oiqq.push(["oiq_addPageCat", "categories:" + dl.categories]);
                  _oiqq.push(["oiq_doTag"]);
                  _oiqq.push(["oiq_addPageLifecycle", "ecv3"]);
                }
                var oiq = document.createElement("script"); oiq.type = "text/javascript"; oiq.async = true; oiq.defer = true;
                oiq.src = document.location.protocol + "//px.owneriq.net/stas/s/0frxgz.js";
                var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(oiq, s);
              },
              callback =  (tcData, success) => {
                if(success && tcData.eventStatus === 'tcloaded') {
                  if( !tcData.gdprApplies || ( tcData.gdprApplies && tcData.tcString ) ){
                    addOipScript();
                  }
                  __tcfapi('removeEventListener', 2, (success) => {}, tcData.listenerId );
                }
              };
            __tcfapi( "addEventListener", 2, callback );
          })(window, window.dataLayer);
        });
      </script>
        
        
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = 'https://btloader.com/tag?o=5642230212591616&upapi=true';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=KBULAM&ncv=24", {"async": "async", "defer": "defer"});
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=all_tsm_sv&ncv=24", {"async": "async", "defer": "defer"});
      });</script>
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = '//townsquare.media/public/resources/js/pubcid.min.js';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        var _comscore = _comscore || [];
        _comscore.push({ c1: "2", c2: "6665296" });
        (function() {
          var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
          el.parentNode.insertBefore(s, el);
        })();
      });</script>
          
          <script>//gdpr 2 - tcfapi stub
      ;!function(){var e=function(){var e,t="__tcfapiLocator",a=[],n=window;for(;n;){try{if(n.frames[t]){e=n;break}}catch(e){}if(n===window.top)break;n=n.parent}e||(!function e(){var a=n.document,r=!!n.frames[t];if(!r)if(a.body){var i=a.createElement("iframe");i.style.cssText="display:none",i.name=t,a.body.appendChild(i)}else setTimeout(e,5);return!r}(),n.__tcfapi=function(){for(var e,t=arguments.length,n=new Array(t),r=0;r<t;r++)n[r]=arguments[r];if(!n.length)return a;if("setGdprApplies"===n[0])n.length>3&&2===parseInt(n[1],10)&&"boolean"==typeof n[3]&&(e=n[3],"function"==typeof n[2]&&n[2]("set",!0));else if("ping"===n[0]){var i={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof n[2]&&n[2](i)}else a.push(n)},n.addEventListener("message",(function(e){var t="string"==typeof e.data,a={};try{a=t?JSON.parse(e.data):e.data}catch(e){}var n=a.__tcfapiCall;n&&window.__tcfapi(n.command,n.version,(function(a,r){var i={__tcfapiReturn:{returnValue:a,success:r,callId:n.callId}};t&&(i=JSON.stringify(i)),e.source.postMessage(i,"*")}),n.parameter)}),!1))};"undefined"!=typeof module?module.exports=e:e()}();</script><script>
      window.cmpFactory = function( varName ) {
        var
          listen = window.attachEvent || window.addEventListener,
          isDebug = RegExp( "debug=([^&]+)" ).exec( location.search );
        listen('message', function(event) {
          window[ varName ].receiveMessage && window[ varName ].receiveMessage(event);
        });

        var commandQueue = [];
        var cmp = function(command, parameter, callback) {
          if( command === "ping" ){
            callback({cmpLoaded: false}, true);
          }else{
            commandQueue.push({
              command: command,
              parameter: parameter,
              callback: callback
            });
          }
        };
        cmp.commandQueue = commandQueue;
        cmp.receiveMessage = function(event) {
          var data = event && event.data && event.data[ varName + "Call" ];
          if (data) {
            commandQueue.push({
              callId: data.callId,
              command: data.command,
              parameter: data.parameter,
              event: event
            });
          }
        };
        cmp.config = {};
        if( isDebug && isDebug[1] && isDebug[1] === "YES" ){
          cmp.config.logging = "debug";
        }
        return cmp;
      };
      window.__cmp = window.cmpFactory( "__cmp" );
      window.__uspapi = window.cmpFactory( "__uspapi" );
    </script><script>
      (function(w) {
        w.TSM.fn.getFile( "//townsquare.media/public/resources/js/cmp.bundle.js", {}, document.head );
        w.cnvr_launcher_options={lid:336};
        w.TSM.fn.getFile( "https://secure.cdn.fastclick.net/js/cnvr-launcher/latest/launcher-stub.min.js", {}, document.head );
      })(window);
    </script>
          <script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
        <script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        </script>
<script async src="//js-sec.indexww.com/ht/p/186854-113710634486999.js"></script>
<script>window.pbjs=window.pbjs||{};window.pbjs.que=window.pbjs.que||[];window.PREBID_TIMEOUT=2000;</script>
<script src="https://cdn.production.townsquareblogs.com/wp-content/uploads/static/prebid/carbon/pb.js?domain=newstalk955.com&v=b7dd1c09524cc4d70c12723e11a7f52ec00a62db&mver=36&gver=3" ></script>

<script>(function(){!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
        var params={pubID:"3227",adServer:"googletag",params:{us_privacy: (RegExp( "usprivacy=([^;]+)" ).exec( document.cookie ) || [])[1] || "1---"}};apstag.init(params);})();</script>


<script>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</script>
          <script defer src="https://apis.google.com/js/platform.js"></script>
      <script>window.twttr = (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0],
        t = window.twttr || {};
      if (d.getElementById(id)) return t;
      js = d.createElement(s);
      js.id = id;
      js.src = "https://platform.twitter.com/widgets.js";
      fjs.parentNode.insertBefore(js, fjs);
      t._e = [];
      t.ready = function(f) {
        t._e.push(f);
      };
      return t;
    }(document, "script", "twitter-wjs"));
    (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, "script", "facebook-jssdk"));
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;t.defer=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '631470830669776');
    fbq('track', 'PageView');</script>
    <script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
    <script>var ZERG = ZERG || {};ZERG.domain = "newstalk955.com";ZERG.user = 751;</script>
          <script type="application/ld+json">{"@context":"https://schema.org","@graph":[{"@context":"https://schema.org/","@type":"NewsMediaOrganization","@id":"https://newstalk955.com/#organization","name":"KCHH-KBUL NewsTalk 95.5","logo":{"@type":"ImageObject","@id":"https://newstalk955.com/#sitelogo","url":"http://newsradio95.com/files/2013/07/NewsTalk951-146-3.png"},"sameAs":["https://newstalk955.com/"]},{"@context":"http://schema.org/","@type":"Website","@id":"https://newstalk955.com/#website","publisher":{"@id":"https://newstalk955.com/#organization"},"name":"KCHH-KBUL NewsTalk 95.5","url":"https://newstalk955.com/"},{"@context":"https://schema.org","@type":"article","headline":"\"Fluffy\" Showed Up Hungry for Some Comedy in Montana","publisher":{"@id":"https://newstalk955.com/#organization"},"url":"https://newstalk955.com/fluffy-showed-up-hungry-for-some-comedy-in-montana/","mainEntityOfPage":{"@type":"WebPage","@id":"https://newstalk955.com/fluffy-showed-up-hungry-for-some-comedy-in-montana/"},"description":"Let's just say Fluffy was hungry to put on a show, especially after all the COVID shutdowns. Comedian Gabriel Iglesias was back in Billings, Montana.","@id":"https://newstalk955.com/fluffy-showed-up-hungry-for-some-comedy-in-montana/#article","image":"//townsquare.media/site/125/files/2022/01/attachment-Fluffy1.jpg","author":{"@type":"Person","name":"Aaron Flint","sameAs":"https://newstalk955.com/author/aaronflint"},"keywords":["fluffy in billings","gabriel iglesias in montana","billings events","billings news","montana news","montana talks","newsletter","politics"],"datePublished":"2022-01-17T00:29:34.000Z","dateCreated":"2022-01-17T00:29:34.000Z","dateModified":"2022-01-17T00:29:34.000Z","isPartOf":{"@id":"https://newstalk955.com/#website"}}]}</script>
        </head>
        <body>
          <div id="fb-root"></div>
          <div id="app">
          <div><header id="site-menu-wrapper" class="" aria-label="site header"><div id="skip-to-main"><a href="#main-content">Skip to main content</a><a href="#site-footer">Skip to site footer</a></div><div class="site-menu-drawer"><ul class="promo-links" aria-label="promoted links"><li><span>Need to Know:</span></li><li><a href="/connect-with-aaron-flint/">Connect With Aaron Flint</a></li><li><a href="/category/local-news-2/">Local News</a></li><li><a href="/category/montana-news/">Montana News</a></li><li><a href="/podcasts/">Montana Talks On Demand</a></li><li><a href="/app">Get NewsTalk 95.5 Mobile App</a></li><li><a href="/newstalk-95-5-is-now-available-on-amazon-alexa-enabled-devices/">Get Newstalk 95.5 on Alexa</a></li></ul></div><div id="site-menu-bg"></div><a class="logo" itemProp="logo url" alt="NewsTalk 95.5" href="/" data-source="logo"><img src="//townsquare.media/site/125/files/2018/03/kbul.png" alt="NewsTalk 95.5"/></a><div class="next-to-logo"><div class="non-menu-content"><div class="admin-bar-wrap"></div><div class="tsm-ad tsm-ad-728"><div id="tsm-ad-728a"><!-- dynamic ad --></div></div></div><nav id="site-menu" class="hide-overflow" aria-label="primary navigation"><div class="wrapper"><ul class="links"><li class="hassub"><a href="/" data-source="nav">Home</a></li><li class="hassub"><a href="/djs" data-source="nav">On Air</a><ul class="links submenu"><li class="hassub"><a href="/djs" data-source="nav">Hosts</a></li><li class="hassub"><a href="/shows" data-source="nav">Schedule</a></li><li class="hassub"><a href="/author/aaronflint/" data-source="nav">Aaron Flint</a></li><li class="hassub"><a href="/show/the-dan-bongino-show/" data-source="nav">Dan Bongino</a></li><li class="hassub"><a href="/author/billingsseanhannity/" data-source="nav">Sean Hannity</a></li><li class="hassub"><a href="/author/marklevinbillings/" data-source="nav">Mark Levin</a></li><li class="hassub"><a href="/author/billingsglennbeck/" data-source="nav">Glenn Beck</a></li><li class="hassub"><a href="/author/daveramseybillings/" data-source="nav">Dave Ramsey</a></li><li class="hassub"><a href="/author/kencolemanbillings/" data-source="nav">Ken Coleman</a></li><li class="hassub"><a href="/author/clewis955/" data-source="nav">Clyde Lewis</a></li><li class="hassub"><a href="/author/billingscoasttocoast/" data-source="nav">George Noory</a></li><li class="hassub"><a href="/author/billingsbillcunningham/" data-source="nav">Bill Cunningham</a></li><li class="hassub"><a href="/author/billingskimkomando/" data-source="nav">Kim Komando</a></li><li class="hassub"><a href="/author/tomgresham/" data-source="nav">Tom Gresham</a></li><li class="hassub"><a href="/author/billingsgarysullivan/" data-source="nav">Gary Sullivan</a></li></ul></li><li class="hassub"><a href="/listen-live/" data-source="nav">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live/" data-source="nav">Listen Live</a></li><li class="hassub"><a href="/app" data-source="nav">Mobile App</a></li><li class="hassub"><a href="/alexa" data-source="nav">Alexa</a></li><li class="hassub"><a href="/googlehome" data-source="nav">Google Home</a></li><li class="hassub"><a href="/podcasts" data-source="nav">On Demand</a></li></ul></li><li class="hassub"><a href="/app" data-source="nav">App</a><ul class="links submenu"><li class="hassub"><a href="/download/ios" data-source="nav">Download iOS</a></li><li class="hassub"><a href="/download/android" data-source="nav">Download Android</a></li></ul></li><li class="hassub"><a href="/contests" data-source="nav">Win Stuff</a><ul class="links submenu"><li class="hassub"><a href="/contests" data-source="nav">Contests</a></li><li class="hassub"><a href="/registration" data-source="nav">Sign Up</a></li><li class="hassub"><a href="/contest-rules/" data-source="nav">Contest Rules</a></li><li class="hassub"><a href="/help" data-source="nav">Contest Support</a></li></ul></li><li class="hassub"><a href="/billings-weather" data-source="nav">Weather</a></li><li class="hassub"><a href="/events-billings/" data-source="nav">Events</a><ul class="links submenu"><li class="hassub"><a href="/events-billings/" data-source="nav">Calendar</a></li><li class="hassub"><a href="/events-billings/community/add" data-source="nav">Submit an Event</a></li></ul></li><li class="hassub"><a href="/tags/local-leaders" data-source="nav">Local Leaders</a><ul class="links submenu"><li class="hassub"><a href="/mortgage-first-fed-billings/" data-source="nav">First Federal Bank &amp; Trust</a></li><li class="hassub"><a href="/remove-your-third-molars-to-save-yourself-from-future-dental-issues/" data-source="nav">Billings Oral Surgery</a></li><li class="hassub"><a href="/thompson-pool-tips/" data-source="nav">Thompson Pools and Spas</a></li><li class="hassub"><a href="/make-sure-your-home-gathering-spaces-are-comfortable/" data-source="nav">Rimrock Cabinet</a></li><li class="hassub"><a href="/gainans-is-celebrating-70-years-in-business/" data-source="nav">Gainan&#x27;s Flowers</a></li><li class="hassub"><a href="/mobility-scooters-improve/" data-source="nav">Juro&#x27;s Pharmacy</a></li><li class="hassub"><a href="/how-to-get-your-skin-ready-for-the-summer-season/" data-source="nav">Montana Medical Aesthetics</a></li></ul></li><li class="hassub"><a href="/help" data-source="nav">Contact Us</a><ul class="links submenu"><li class="hassub"><a href="/help" data-source="nav">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback" data-source="nav">Send Feedback</a></li><li class="hassub"><a href="/employment-opportunities/" data-source="nav">Employment Opportunities</a></li><li class="hassub"><a href="/advertise" data-source="nav">Advertise</a></li></ul></li><li class="hidden-menu hassub hide"><div class="more-icon link" aria-hidden="true">More</div><ul class="links submenu"><li class="hassub hide"><a href="/" data-source="nav">Home</a></li><li class="hassub hide"><a href="/djs" data-source="nav">On Air</a><ul class="links submenu"><li class="hassub"><a href="/djs" data-source="nav">Hosts</a></li><li class="hassub"><a href="/shows" data-source="nav">Schedule</a></li><li class="hassub"><a href="/author/aaronflint/" data-source="nav">Aaron Flint</a></li><li class="hassub"><a href="/show/the-dan-bongino-show/" data-source="nav">Dan Bongino</a></li><li class="hassub"><a href="/author/billingsseanhannity/" data-source="nav">Sean Hannity</a></li><li class="hassub"><a href="/author/marklevinbillings/" data-source="nav">Mark Levin</a></li><li class="hassub"><a href="/author/billingsglennbeck/" data-source="nav">Glenn Beck</a></li><li class="hassub"><a href="/author/daveramseybillings/" data-source="nav">Dave Ramsey</a></li><li class="hassub"><a href="/author/kencolemanbillings/" data-source="nav">Ken Coleman</a></li><li class="hassub"><a href="/author/clewis955/" data-source="nav">Clyde Lewis</a></li><li class="hassub"><a href="/author/billingscoasttocoast/" data-source="nav">George Noory</a></li><li class="hassub"><a href="/author/billingsbillcunningham/" data-source="nav">Bill Cunningham</a></li><li class="hassub"><a href="/author/billingskimkomando/" data-source="nav">Kim Komando</a></li><li class="hassub"><a href="/author/tomgresham/" data-source="nav">Tom Gresham</a></li><li class="hassub"><a href="/author/billingsgarysullivan/" data-source="nav">Gary Sullivan</a></li></ul></li><li class="hassub hide"><a href="/listen-live/" data-source="nav">Listen</a><ul class="links submenu"><li class="hassub"><a href="/listen-live/" data-source="nav">Listen Live</a></li><li class="hassub"><a href="/app" data-source="nav">Mobile App</a></li><li class="hassub"><a href="/alexa" data-source="nav">Alexa</a></li><li class="hassub"><a href="/googlehome" data-source="nav">Google Home</a></li><li class="hassub"><a href="/podcasts" data-source="nav">On Demand</a></li></ul></li><li class="hassub hide"><a href="/app" data-source="nav">App</a><ul class="links submenu"><li class="hassub"><a href="/download/ios" data-source="nav">Download iOS</a></li><li class="hassub"><a href="/download/android" data-source="nav">Download Android</a></li></ul></li><li class="hassub hide"><a href="/contests" data-source="nav">Win Stuff</a><ul class="links submenu"><li class="hassub"><a href="/contests" data-source="nav">Contests</a></li><li class="hassub"><a href="/registration" data-source="nav">Sign Up</a></li><li class="hassub"><a href="/contest-rules/" data-source="nav">Contest Rules</a></li><li class="hassub"><a href="/help" data-source="nav">Contest Support</a></li></ul></li><li class="hassub hide"><a href="/billings-weather" data-source="nav">Weather</a></li><li class="hassub hide"><a href="/events-billings/" data-source="nav">Events</a><ul class="links submenu"><li class="hassub"><a href="/events-billings/" data-source="nav">Calendar</a></li><li class="hassub"><a href="/events-billings/community/add" data-source="nav">Submit an Event</a></li></ul></li><li class="hassub hide"><a href="/tags/local-leaders" data-source="nav">Local Leaders</a><ul class="links submenu"><li class="hassub"><a href="/mortgage-first-fed-billings/" data-source="nav">First Federal Bank &amp; Trust</a></li><li class="hassub"><a href="/remove-your-third-molars-to-save-yourself-from-future-dental-issues/" data-source="nav">Billings Oral Surgery</a></li><li class="hassub"><a href="/thompson-pool-tips/" data-source="nav">Thompson Pools and Spas</a></li><li class="hassub"><a href="/make-sure-your-home-gathering-spaces-are-comfortable/" data-source="nav">Rimrock Cabinet</a></li><li class="hassub"><a href="/gainans-is-celebrating-70-years-in-business/" data-source="nav">Gainan&#x27;s Flowers</a></li><li class="hassub"><a href="/mobility-scooters-improve/" data-source="nav">Juro&#x27;s Pharmacy</a></li><li class="hassub"><a href="/how-to-get-your-skin-ready-for-the-summer-season/" data-source="nav">Montana Medical Aesthetics</a></li></ul></li><li class="hassub hide"><a href="/help" data-source="nav">Contact Us</a><ul class="links submenu"><li class="hassub"><a href="/help" data-source="nav">Help &amp; Contact Info</a></li><li class="hassub"><a href="/feedback" data-source="nav">Send Feedback</a></li><li class="hassub"><a href="/employment-opportunities/" data-source="nav">Employment Opportunities</a></li><li class="hassub"><a href="/advertise" data-source="nav">Advertise</a></li></ul></li></ul></li></ul><div class="site-menu-right"><a class="listen-live-cto cto" style="min-width:300px"></a><ul class="social-links"><li class="social"><a class="share-link youtube" href="https://youtube.com/user/newstalk955" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="icon-base icon-youtube" aria-hidden="true"></span><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share-link facebook" href="https://www.facebook.com/NewsTalk955" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="icon-base icon-facebook" aria-hidden="true"></span><span class="visually-hidden">Visit us on Facebook</span></a></li><li class="social"><a class="share-link instagram" href="https://www.instagram.com/newstalk970" target="_blank" rel="noopener noreferrer" data-social="instagram"><span class="icon-base icon-instagram" aria-hidden="true"></span><span class="visually-hidden">Visit us on Instagram</span></a></li><ul class="social-subscriptions"><li class="sub-instagram "><a href="https://www.instagram.com/newstalk970" target="_blank" rel="noopener noreferrer">INSTAGRAM</a></li><li class="share_link_small youtube sub-youtube"></li><li class="sub-facebook"></li></ul></ul><div id="search-form" class=""><div class="form-wrap"></div><div class="icon-base icon-search"></div></div></div><div class="site-screen select-none"></div></div></nav></div></header><div id="container" class=""><div id="top-not-ads" class=""><div id="tsm-ad-1x1-container"><div class="tsm-ad tsm-ad-oop"><div id="tsm-ad-oop"><!-- dynamic ad --></div></div></div></div><div class="tsm-ad tsm-ad-nav-970"><div id="tsm-ad-970a"><!-- dynamic ad --></div></div><div class="container-inner"><div class="site-content clearfix"><main id="main-content" class="main-content" tabindex="-1"><div class="wrapper post-wrapper"><div class="internal-header outgrow " style="max-height:0px"></div><div class="post clearfix"><div class="entry"><article id="post-294380" data-location="/fluffy-showed-up-hungry-for-some-comedy-in-montana/" data-index="0" class=""><div class="page-header"><div class="content-header show-ui front" id="content-header-294380"><div class="content-header-header"><div class="react-parallax"><figure class="frameme temp-ssr" alt="&amp;#8220;Fluffy&amp;#8221; Showed Up Hungry for Some Comedy in Montana"><img src="//townsquare.media/site/125/files/2022/01/attachment-Fluffy1.jpg?w=980&amp;q=75" alt="&amp;#8220;Fluffy&amp;#8221; Showed Up Hungry for Some Comedy in Montana"/></figure></div><div class="header"><section class="title "><h1 class="">“Fluffy” Showed Up Hungry for Some Comedy in Montana</h1></section><div class="byline"><div class="author-image"><div class="icon-user" aria-hidden="true"></div><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/990/files/2020/03/Aaron-Flint-500-x-5001.png" href="//newstalk955.com/author/aaronflint/" rel="author"><figcaption class="visually-hidden">Aaron Flint</figcaption></a></figure></div><div class="not-author-image-stuff"><div class="not-author-image-stuff-row"><a class="author-name" href="//newstalk955.com/author/aaronflint/" rel="author">Aaron Flint</a><time dateTime="2022-01-17 02:29:34 +0000">Published: January 16, 2022</time></div></div></div><figcaption>Credit Aaron Flint</figcaption></div></div></div></div><div class="content-wrap"><div class="social-share bignsexy"><div class="social-bar social-icons"><ul><li><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fnewstalk955.com%2Ffluffy-showed-up-hungry-for-some-comedy-in-montana%2F%3Ftrackback%3Dfbshare_mobile" title="Share on Facebook" target="_blank"><span class=" social-icon icon-facebook fb"><span class="share-title">Share on Facebook</span></span></a></li><li><a href="http://twitter.com/intent/tweet?text=%E2%80%9CFluffy%E2%80%9D%20Showed%20Up%20Hungry%20for%20Some%20Comedy%20in%20Montana%20http%3A%2F%2Fnewstalk955.com%2Ffluffy-showed-up-hungry-for-some-comedy-in-montana%2F%3Ftrackback%3Dtwitter_mobile%20" title="Share on Twitter" target="_blank"><span class=" social-icon icon-twitter tw"><span class="share-title">Share on Twitter</span></span></a></li></ul></div></div><div class="content"><div class="pod-content"><p>Let&apos;s just say Fluffy was hungry. He was hungry to put on a show.</p><p>After an extended shutdown of the major comedy shows due to COVID-19 restrictions across the country, comedian Gabriel Iglesias was back in Billings, Montana for his second show of the year.</p><p>At one point late in the night, Gabriel Iglesias (aka Fluffy) finally told the crowd, &quot;you know the show ended like 25 minutes ago, right?&quot; And then he picked up his show clock off the floor of the stage at the Metra in Billings and showed the crowd how he already went over time by 25 minutes. Then he kept going for at least another 45 minutes. And the crowd was rolling with him for every second.</p><div class="in-article-oop-container"><div class="tsm-ad tsm-ad-oop"><div id="tsm-ad-in-article-oop-1"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-1x1 tsm-ad-oop"><div id="tsm-ad-in-article-pixel-1"><!-- dynamic ad --></div></div></div><p>I won&apos;t give away any of the jokes, as the crowd had to promise not to take any videos or give away any of the punchlines in what could be featured in his soon to be recorded Netflix special. However, let&apos;s just say Fluffy delivered jokes about COVID-19 that had both sides laughing- masked or unmasked. And he took on cancel culture and the critics who attacked him for playing the role of Speedy Gonzales in the new Space Jam movie.</p><p>Thankfully as Fluffy and Martine&#xA0;were about to leave the stage, he let the crow whip out our cellphones and snap some photos before they departed.</p><div class="single-post-image"><figure class="img-tag has-sizer alignnone"><div class="frame-sizer" style="padding-top:56.25%"></div><div class="theframe" data-image="//townsquare.media/site/125/files/2022/01/attachment-Fluffy2.jpg" rel=""><span class="visually-hidden">Credit Aaron Flint</span></div><figcaption>Credit Aaron Flint</figcaption><div class="loadinganim showbox" id="0"><div class="loader" style="width:30px;height:30px"><svg class="circular" viewBox="25 25 50 50" style="width:30px;height:30px" focusable="false" role="img" aria-labelledby="loading-anim-title"><title id="loading-anim-title">loading...</title><circle class="path" cx="50" cy="50" r="20" fill="none" stroke-width="4" stroke-miterlimit="10"></circle></svg></div></div></figure><div></div></div><div class="single-post-image"><figure class="img-tag has-sizer alignnone"><div class="frame-sizer" style="padding-top:56.25%"></div><div class="theframe" data-image="//townsquare.media/site/125/files/2022/01/attachment-Fluffy3.jpg" rel=""><span class="visually-hidden">Credit Aaron Flint</span></div><figcaption>Credit Aaron Flint</figcaption><div class="loadinganim showbox" id="0"><div class="loader" style="width:30px;height:30px"><svg class="circular" viewBox="25 25 50 50" style="width:30px;height:30px" focusable="false" role="img" aria-labelledby="loading-anim-title"><title id="loading-anim-title">loading...</title><circle class="path" cx="50" cy="50" r="20" fill="none" stroke-width="4" stroke-miterlimit="10"></circle></svg></div></div></figure><div></div></div><p>&#xA0;</p><div class="photogallery-wrapper"><h2 class="photogallery-title">CHECK IT OUT: The Best Movie Character Names of the 1980s</h2></div><p>&#xA0;</p></div></div><div class="content-footer"><div class="tags-lines"><div class="wrapper tags"><span>Filed Under<!-- -->: </span><span><a href="//newstalk955.com/tags/comedy/">comedy</a></span></div><div class="wrapper categories"><span>Categories<!-- -->: </span><span><a href="//newstalk955.com/category/billings-events/">Billings Events</a></span><span>, <a href="//newstalk955.com/category/local-news-2/">Billings News</a></span><span>, <a href="//newstalk955.com/category/montana-news/">Montana News</a></span><span>, <a href="//newstalk955.com/category/montana-talks/">Montana Talks</a></span><span>, <a href="//newstalk955.com/category/newsletter/">Newsletter</a></span><span>, <a href="//newstalk955.com/category/politics/">Politics</a></span></div></div><div class="comments-wrapper"><div class="comments"><div><i>Comments</i><span class="icon-triangle-down" aria-hidden="true"></span></div><div class="cto">Leave A Comment</div></div></div><div class="lazyload-placeholder zergnet-lazyload-placeholder"></div><div class="goto-top-container outgrow"><a class="goto-top icon-triangle-left" href="#main-content" data-index="0">Back To Top</a></div></div></div></article></div></div></div></main><aside class="main-aside" aria-label="sidebar"></aside></div><section class="site-footer"><footer id="site-footer" tabindex="-1"><div class="links clearfix"><div class="logo"></div><div class="details"><h2>Information</h2><ul><li class=""><a href="/eeo/" aria-label="EEO Public File">EEO Public File</a></li><li class=""><a href="/advertising-and-marketing-for-business/billings-mt/" aria-label="Marketing and Advertising Solutions">Marketing and Advertising Solutions</a></li><li class="next-one-merge"><a href="https://publicfiles.fcc.gov/am-profile/KBUL" aria-label="Public File">Public File</a></li><li class=""><a href="/kchh-kbul-public-file/" aria-label="Persons with disabilities who need assistance with the KCHHFM &amp; KBULAM / KCHH-KBUL Public File">Need Assistance</a></li><li class=""><a href="/fcc-applications/" aria-label="FCC Applications">FCC Applications</a></li><li class=""><a href="/report-an-inaccuracy" aria-label="Report an Inaccuracy">Report an Inaccuracy</a></li><li class=""><a href="/terms/" aria-label="Terms">Terms</a></li><li class=""><a href="/vip-terms/" aria-label="VIP Terms">VIP Terms</a></li><li class=""><a href="/vip-faq/" aria-label="FAQ">FAQ</a></li><li class=""><a href="/contest-rules/" aria-label="Contest Rules">Contest Rules</a></li><li class=""><a href="/privacy/" aria-label="Privacy Policy">Privacy Policy</a></li><li class=""><a href="/digital-accessibility-statement/" aria-label="Accessibility Statement">Accessibility Statement</a></li><li class=""><a href="/privacy/preferences/" aria-label="Exercise My Data Rights">Exercise My Data Rights</a></li><li class=""><a href="/help/" aria-label="Contact">Contact</a></li><li class=""><a href="/billings-featured-business-listings/" aria-label="Billings Business Listings">Billings Business Listings</a></li></ul></div><div class="social-links"><h2>Follow Us</h2><ul><li class="social"><a class="share_link instagram" href="https://www.instagram.com/newstalk970" target="_blank" rel="noopener noreferrer" data-social="instagram"><span class="icon-instagram" aria-hidden="true"></span><span class="visually-hidden">Visit us on Instagram</span></a></li><li class="social"><a class="share_link youtube" href="https://www.youtube.com/user/newstalk955" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="icon-youtube" aria-hidden="true"></span><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share_link facebook" href="https://www.facebook.com/NewsTalk955" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="icon-facebook" aria-hidden="true"></span><span class="visually-hidden">Visit us on Facebook</span></a></li></ul></div></div><div class="legal">2022<!-- --> <!-- -->NewsTalk 95.5<!-- -->, <a href="http://www.townsquaremedia.com">Townsquare Media</a>, Inc. All rights reserved.</div></footer></section></div><section class="bottom-components"><div id="bottom-not-ads"><div class="tsm-ad tsm-ad-728"><div id="tsm-ad-728b"><!-- dynamic ad --></div></div><div><!-- interstitial slot inactive --></div></div></section></div></div></div>
          <script style="display: none;">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</script>
          
          
          
          
          
          
          
          
          
          
          <script>(function(d){
            var getFile = window.TSM.fn.getFile;
            try{
              let
                getDependencies = function(){
                  return new Promise(async function( res, rej ){
                    var dependencies = ["//townsquare.media/public/dist/desktop/main.bundle.b7dd1c09524cc4d70c12723e11a7f52ec00a62db.js?mver=36&gver=3"];
                    for(var i=0;i<dependencies.length;i++){
                      await getFile( dependencies[i] );
                    }
                    res({});
                  });
                },
                getInitialState = function(){
                  return fetch( [ location.pathname, location.search, ( location.search ? "&" : "?" ), "initialState=b7dd1c09524cc4d70c12723e11a7f52ec00a62db" ].join( "" ) )
                    .then( response => {
                      if( !response.ok ){
                        if( response.status === 404 ){
                          return response;
                        }
                        throw Error( response.statusText );
                      }
                      return response;
                    })
                    .then( response => response.json() )
                    .catch(( err )=>{
                      console.log( "Carbon - Error in Rest response", err );
                    });
                };
              let allTasks = [ getDependencies() ];Promise.all( allTasks )
                  .then(function(results){
                    window.initCarbon && window.initCarbon();
                  });
            }catch(e){console.error(e);}
          })(document);</script>
          
        </body>
      </html>